Tuesday 26 June 2012

IBM AIX Interview Questions with Answers

AIX Faqs-->1

1. How do you create an LV?

Ans: #mklv –y lv_name vg_name PPs pv_name

2. How do you create a filesystem on a given LV?

Ans: # crfs –v jfs –d /dev/lv_name –m /mount_point

3. What is Journaled File System?

Ans: It maintains a log in corresponding log device before committing any changes to LV and thus maintains integrity of file system.

4. What are the types of filesystems in AIX?

Ans: JFS, JFS2, CDRFS, NFS

5. What are the differences between JFS and JFS2 FS?

Ans:  JFS- inode allocation while creating file systems is static
         JFS2 – Inode allocation is dynamic
         JFS- maximum file system size is 1 TB
         JFS2- Maximum file system size is 4 PB
         JFS- Inode size is 128 Bytes
         JFS2 – Inode size is 512 bytes

6. What is the file responsible to tell about the filesystems?

Ans: /etc/filesystems

7. How will you troubleshoot the file system problem?

Ans: using fsck and logform

8. Where you keep the shared folders in AIX?

Ans: /etc/exports

9. What exportfs –a command does?

Ans: It reads entries from /etc/exports and updates /etc/xtab

10. What is inode?

Ans: It is an Index node and points to the another inode or a datablock

11. What is superblock?

Ans: First block of any file system and contains Meta data of its like no of inodes and free list of inodes etc.

12. What is the daemon responsible for error log?

Ans: errdemon

13. What is the path for default log file?

Ans: /var/adm/ras/errorlog

14. How do you restrict remote user?

Ans: chuser rlogin=false user_name

15. How do you list filesystems?

Ans: lsfs

16. What are the stanzas in /etc/filesystem?

Ans: dev=, Mount=, Log=, Vfs=, Check=, Type=
         
17. How do you check error log?

Ans: # errpt -a

18. What is /proc file system?

Ans: contains process related information of all processes which are presently running.

19. What is the command to change the password of another user by a user –admin 
(other than root user) who can set the passwords for users?

Ans: pwdadm

20. In the above question user “admin” belongs to which group?

Ans. Security

21. How will you set the password for a user whose password length must be eight 
characters?
ANS: SMIT CHUSER OR # CHUSER MINLEN=8 USER_NAME ENTRIES WILL BE UPDATED IN /ETC/SECURITY/USER

22. Where is the password for a user stores?

Ans: /etc/security/passwd

23. What are the fields available in the: /etc/security/passwd file?

Ans: last update, password and flag

24. What are the fields available in /etc/passwd file?

Ans: username: password indication: uid: gid: gcos: homedirectory: shell

25. What are the actions will take happen while exporting vg?

Ans: Removes that vg entry from odm
Removes corresponding filesystem entries related to VG from /etc/filesystems.

26. One VG is exported from a system and imported in another system there created some new filesystems in that VG. Now to import that VG back to the old system what command you should execute?

ANS:   importvg –L –y vgname pvname

27. What is the VGDA information?

Ans: VG id, LV names, PV count, total PP’s, free PP’s, lv count, LTG etc.
(Use   # lqueryvg –p hdiskx –At)

28. While importing VG the /etc/filsystems will get updated, from where the information of file systems it gets?

Ans: LVCB of each lv (mount point information will reside in LVCB if the mount point length is less than 128 characters)

29. How will you set the customized UMASK for all users?

Ans: Add the entry in /etc/security/user- In default Section

30. What is LVM and its components?  What is the advantage of LVM in AIX.?

Ans: VG, PV, LV, FILESYSTEMS, File systems can be extended beyond the limit of PV size to multiple PVs.

31.  Can we add PV of different sizes into an existing VG? How to fully utilize the hdd space?

Ans Yes we can add PV of different sizes to existing VG. Change t factor

32. How you find out the characteristics of VG? What are the main features you look for?

Ans: #lsvg vgname.   NO. PPs, Free PPs, stale PPs etc

33. What is stale partition?

Ans: When a pp is out of synchronization it shows as stale partition.

34. How many PPs can be pointed by a LP? Is the size of LP increases with mirroring of PPs?

Ans: 3 PPs can be pointed a LP. No the size of LP does not increase with PP mirroring

35. What are the information you get in VGDA ?

Ans: PP size, PV count, max PPs, LV names etc, Free PPs,

36. What is the difference between VGDA & VGSA?

Ans:

37. What is LVCB?

Lvname, no of copies, inter policy, intra policy, no. of lps, lvid etc

38. What is quorum? Give details?

Ans: 51% of total VGDA information is called quorum

39. What is ‘t’ factor?

Ans:  by t factor we can increase max no. of PPs from default 1016. Ex: t2 will make 2032 max physical partitions.

40. How you make concurrent VG ?

Ans: mkvg –C –y vgname pvname

41. What are daemons in NFS ? Give details of each daemon ?

Ans : nfsd, rpc.mountd, rpc.statd, rpc.lockd and at client side biod

42. When we reopen an exported file after working on it we get stale error. What is the reason ?

 Ans :

43. What is the difference between network interface and network devices?

Ans: interface is logical device for tcpip networking, network devices are physical adapter.

44. How to add IP by aliasing to a network device ?

Ans: ifconfig en0 193.9.200.227 255.255.255.0 alias

45. What is netmask ?

Ans: to differentiate between network address and host address.

46. Give an example of class B network?

Ans:  130.10.200.0

47. What is loopback address and its utility ?

Ans: IP address 127.0.0.1 is called loopback address and is used by the node to check the functioning of  its own tcpip sevices.

48. Where to add gateway in the network ? Can we use router as gateway ?

Ans: to connect between two different networks. Yes we can use router as gateway.

49. What is the difference between /etc/passwd and /etc/security/passwd ?

Ans: user information are stored in /etc/passwd . encrypted passwd is stored /etc/security/passwd

50. How to disable the lock of a user when he has crossed the failed login limits? Which is 
the file to look into it?

Ans: chuser account_locked=true user. /etc/security/user

51. What is the difference between systemwide profile and .profile of an user ?

Ans: ./profile of user overrides the env variables set by /etc/profile

52. What difference you find in #su root and #su – root ?

Ans: Su – root initializes the environment to that of root.

53. What is umask and why we require it ?

Ans: The umask value is deducted from default permission value 777 of a file when created.

54. What is tcb and how it works ?

Ans:  trusted computing base. When it is enable only trusted commands are executed by verifying with /etc/security/sysck.cfg.

55. What is quota and give full syntax of commands?

Ans: it fixes the limits for files and sizes for each user. Quota

56. What is trusted path and trusted shell?

Ans:

57. How you enable ACL in a file?

Ans: extended permission to be set in file. To set use the command acledit,aclget,aclput

58. How to find out the characteristics of an user ? What is difference between #lsuser and #lsattr?

Ans: lsuser, by lsattr we can find out the attributes of a device

59. What is the procedure to configure remote printer?

Ans: enable lpd daemon, create a queue and connect it to remote queue

60. What is difference between defined and available state in ODM ?

Ans: defined means it is already configured but not available for use. Available means the device is ready for use.

61. How you see maintenance level in AIX? What is the other command than #oslevel –r?

Ans: instfix

62. How you install ML in AIX?   

Ans: #smitty update_all

63. What is the procedure in installing a package in AIX ? What is applied , commited, 
rejected states ?

Ans: applied –for testing of package only, committed: to install the package into the system. Reject: to reject the package if it fails in applied state

64. Can we install ML5 and ML6 simultaneously in applied state in same machine?

Ans: yes we can

65. If we remove ML5 from the m/c, will the ML6 will work ?

Ans: yes it will work

66. What is difference between backup and archive ?

Ans: archive: the backup data stored permanently for retrieval later date. Backup is a regular process like full backup, differential backup, incremental backup.

67. What is the difference between incremental and differential backup ?

Ans: In diff. Bacup it is compared with last full backup. In incremental backup it is compared to last backup.

68. What is crontab and how to schedule a job to run at 5pm on every Saturday?

Ans: to schedule to run a process at particular time. Edit the crontab file by crontab –e or crotab –l > crontmp, edit the crontmp by syntax m, h, day of month, month, day of week /process. Then start the process by crontab crontmp

69. What is the location where cron queues are being maintained?

Ans: /var/spool/cron/crontabs

70. Where errorlog files are stored ?

Ans: /var/adm/ras/errlog

0 comments:

Post a Comment